summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/remote-build/master.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/remote-build/master.nix')
-rw-r--r--makefu/2configs/remote-build/master.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/makefu/2configs/remote-build/master.nix b/makefu/2configs/remote-build/master.nix
new file mode 100644
index 00000000..4ad2c5ed
--- /dev/null
+++ b/makefu/2configs/remote-build/master.nix
@@ -0,0 +1,14 @@
+{ pkgs, ...}:
+let
+ sshKey = (toString <secrets>) + "/id_nixBuild";
+in {
+ nix.distributedBuilds = true;
+ # TODO: iterate over krebs.hosts
+ nix.buildMachines = map ( hostName:
+ { inherit hostName sshKey;
+ sshUser = "nixBuild";
+ system = "x86_64-linux";
+ maxJobs = 1;
+ }) [ "omo.r" "gum.r" "latte.r" ];
+ # puyak.r "wbob.r"
+}