summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/nginx/iso.euer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/nginx/iso.euer.nix')
-rw-r--r--makefu/2configs/nginx/iso.euer.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/makefu/2configs/nginx/iso.euer.nix b/makefu/2configs/nginx/iso.euer.nix
deleted file mode 100644
index 701609d4..00000000
--- a/makefu/2configs/nginx/iso.euer.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{ config, pkgs, ... }:
-let
- system = builtins.currentSystem; #we can also build for other platforms
- iso = (import <nixpkgs/nixos/lib/eval-config.nix>
- { inherit system;
- modules = [ ../../1systems/iso/config.nix ]; }
-
- );
- image = iso.config.system.build.isoImage;
- name = iso.config.isoImage.isoName;
-
- drivedroid-cfg = builtins.toJSON [{
- id = "stockholm";
- imageUrl = http://krebsco.de/krebs-v2.png;
- name = "stockholm";
- tags = [ "hybrid" ];
- url = http://krebsco.de;
- releases = [
- { version = iso.config.system.nixos.label;
- url = "/stockholm.iso";
- arch = system; }
- ];
- # size = TODO;
- }];
- web = pkgs.linkFarm "web" [{
- name = "drivedroid.json";
- path = pkgs.writeText "drivedroid.json" drivedroid-cfg; }
- { name = "stockholm.iso";
- path = "${image}/iso/${name}"; }
- ];
-in
-{
- services.nginx = {
- virtualHosts = {
- "iso.euer.krebsco.de" = {
- enableACME = true;
- forceSSL = true;
- root = web;
- locations."/".index = "drivedroid.json";
- };
- };
- };
-}