summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/minimal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/minimal.nix')
-rw-r--r--makefu/2configs/minimal.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/makefu/2configs/minimal.nix b/makefu/2configs/minimal.nix
index d764e562..cb2ef09e 100644
--- a/makefu/2configs/minimal.nix
+++ b/makefu/2configs/minimal.nix
@@ -7,8 +7,8 @@
# the only true timezone (even after the the removal of DST)
time.timeZone = "Europe/Berlin";
- networking.hostName = config.krebs.build.host.name;
- nix.buildCores = config.krebs.build.host.cores;
+ networking.hostName = lib.mkIf (lib.hasAttr "host" config.krebs.build) config.krebs.build.host.name;
+ nix.buildCores = 0; # until https://github.com/NixOS/nixpkgs/pull/50440 is in stable
# we use gpg if necessary (or nothing at all)
programs.ssh.startAgent = false;
@@ -85,4 +85,6 @@
"net.ipv6.conf.all.use_tempaddr" = 2;
"net.ipv6.conf.default.use_tempaddr" = 2;
};
+
+ services.nscd.enable = false;
}