summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/hw/tp-x220.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/hw/tp-x220.nix')
-rw-r--r--makefu/2configs/hw/tp-x220.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/makefu/2configs/hw/tp-x220.nix b/makefu/2configs/hw/tp-x220.nix
new file mode 100644
index 00000000..f0392215
--- /dev/null
+++ b/makefu/2configs/hw/tp-x220.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+
+ imports = [ ./tp-x2x0.nix ];
+
+ boot.kernelModules = [ "kvm-intel" ];
+
+ services.xserver = {
+ videoDriver = "intel";
+ vaapiDrivers = [ pkgs.vaapiIntel pkgs.vaapiVdpau ];
+ deviceSection = ''
+ Option "AccelMethod" "sna"
+ '';
+ };
+
+ services.xserver.displayManager.sessionCommands =''
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation" 8 1
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Button" 8 2
+ xinput set-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Axes" 6 7 4 5
+ # xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Timeout" 8 200
+ '';
+
+}