summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/hw/smartcard.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/hw/smartcard.nix')
-rw-r--r--makefu/2configs/hw/smartcard.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/makefu/2configs/hw/smartcard.nix b/makefu/2configs/hw/smartcard.nix
new file mode 100644
index 00000000..1e9bca53
--- /dev/null
+++ b/makefu/2configs/hw/smartcard.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+{
+ services.pcscd = {
+ enable = true;
+ plugins = with pkgs; [ ifdnfc ccid ];
+
+ };
+ environment.systemPackages = with pkgs; [
+ # need to run ifdnfc-activate before usage
+ ifdnfc
+ # pcsc_scan
+ pcsctools
+ ];
+ boot.blacklistedKernelModules = [
+ "pn533" "pn533_usb"
+ "nfc"
+ ];
+}