summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/signal-rest/pkg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/signal-rest/pkg.nix')
-rw-r--r--makefu/2configs/home/ham/signal-rest/pkg.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/makefu/2configs/home/ham/signal-rest/pkg.nix b/makefu/2configs/home/ham/signal-rest/pkg.nix
new file mode 100644
index 00000000..165d642a
--- /dev/null
+++ b/makefu/2configs/home/ham/signal-rest/pkg.nix
@@ -0,0 +1,25 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+ pname = "pysignalclirestapi";
+ version = "0.3.14";
+
+ # disabled = ; # requires python version >=2.7
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "6f3626b594a53c4161dfc67ea7a3b23d62c8fe8cb404a909496118aeefa79cd0";
+ };
+
+ doCheck = false;
+
+ meta = with lib; {
+ description = "Small python library for the Signal Cli REST API";
+ homepage = https://github.com/bbernhard/pysignalclirestapi;
+ #license = licenses.;
+ # maintainers = [ maintainers. ];
+ };
+}