summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/lib/cheat-sheet.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/lib/cheat-sheet.nix')
-rw-r--r--makefu/2configs/home/ham/lib/cheat-sheet.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/makefu/2configs/home/ham/lib/cheat-sheet.nix b/makefu/2configs/home/ham/lib/cheat-sheet.nix
new file mode 100644
index 00000000..f593ef4e
--- /dev/null
+++ b/makefu/2configs/home/ham/lib/cheat-sheet.nix
@@ -0,0 +1,42 @@
+# Begin
+let
+in {
+ services.home-assistant.config.automation =
+ [
+ ];
+}
+
+# example automation
+ { alias = "";
+ trigger = [
+ {
+ platform = "state";
+ entity_id = "";
+ to = "on";
+ for.seconds = 0;
+ }
+ ];
+ condition = [
+ { condition = "state";
+ entity_id = "";
+ state = "off";
+ }
+ ];
+ action =
+ [
+ { choose = [
+ {
+ conditions = {
+ condition = "state";
+ entity_id = "";
+ state = "on";
+ };
+ sequence = [{
+ service = "home_assistant.turn_on";
+ target.entity_id = "";
+ }];
+ }];
+ default = { };
+ }
+ ];
+ }