summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/deps/pykodi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/deps/pykodi.nix')
-rw-r--r--makefu/2configs/home/ham/deps/pykodi.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/makefu/2configs/home/ham/deps/pykodi.nix b/makefu/2configs/home/ham/deps/pykodi.nix
deleted file mode 100644
index 85a541f8..00000000
--- a/makefu/2configs/home/ham/deps/pykodi.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ lib
-, buildPythonPackage
-, fetchPypi
-, jsonrpc-async
-, jsonrpc-websocket
-, aiohttp
-}:
-
-buildPythonPackage rec {
- pname = "pykodi";
- version = "0.2.2";
-
- disabled = false; # requires python version >=3.7.0
-
- src = fetchPypi {
- inherit pname version;
- sha256 = "43e7036a00a76f65c34dc5e7f1065a3ef071eea7619c2e6228e521b638e640bc";
- };
-
- # # Package conditions to handle
- # # might have to sed setup.py and egg.info in patchPhase
- # # sed -i "s/<package>.../<package>/"
- # jsonrpc-async>=1.1.0
- # jsonrpc-websocket>=1.2.1
- propagatedBuildInputs = [
- jsonrpc-async
- jsonrpc-websocket
- aiohttp
- ];
-
- meta = with lib; {
- description = "An async python interface for Kodi over JSON-RPC";
- homepage = https://github.com/OnFreund/PyKodi;
- license = licenses.mit;
- # maintainers = [ maintainers. ];
- };
-}