summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix')
-rw-r--r--makefu/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/makefu/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix b/makefu/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix
new file mode 100644
index 00000000..3aaa57bd
--- /dev/null
+++ b/makefu/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix
@@ -0,0 +1,39 @@
+let
+ notify_felix = message: {
+ service = "notify.signal_felix";
+ data.message = message;
+ };
+ notify_home = message: {
+ service = "notify.signal_home";
+ data.message = message;
+ };
+in
+{
+ services.home-assistant.config.automation =
+ [
+ {
+ alias = "Pflanzen Giessen Erinnerung Daily";
+ trigger = {
+ platform = "time";
+ at = "12:15:00";
+ };
+ action = [
+ (notify_felix "Es ist Mittagszeit und du kannst ruhig einmal alle Blumen im Zimmer giessen")
+ ];
+ }
+ {
+ alias = "Pflanzen Giessen Erinnerung Weekly";
+ trigger = {
+ platform = "time";
+ at = "12:15:00";
+ };
+ condition = {
+ condition = "time";
+ weekday = [ "sat" ];
+ };
+ action = [
+ (notify_home "Es ist Wochenende und die Pflanzen würden sich über ein bisschen Wasser freuen.")
+ ];
+ }
+ ];
+}