summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/automation/ladestecker_timer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/automation/ladestecker_timer.nix')
-rw-r--r--makefu/2configs/home/ham/automation/ladestecker_timer.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/makefu/2configs/home/ham/automation/ladestecker_timer.nix b/makefu/2configs/home/ham/automation/ladestecker_timer.nix
new file mode 100644
index 00000000..8e877129
--- /dev/null
+++ b/makefu/2configs/home/ham/automation/ladestecker_timer.nix
@@ -0,0 +1,24 @@
+let
+ relay = "switch.terrasse_plug_relay";
+ timeout = "300";
+in {
+ services.home-assistant.config.automation = [
+ { alias = "Always turn off Charging station after ${toString (timeout)}m";
+ trigger = [
+ {
+ platform = "state";
+ entity_id = relay;
+ to = "on";
+ for.minutes = timeout;
+ }
+ ];
+ action =
+ [
+ {
+ service = "homeassistant.turn_off";
+ entity_id = [ relay ];
+ }
+ ];
+ }
+ ];
+}