summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/graphite-standalone.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/graphite-standalone.nix')
-rw-r--r--makefu/2configs/graphite-standalone.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/makefu/2configs/graphite-standalone.nix b/makefu/2configs/graphite-standalone.nix
new file mode 100644
index 00000000..50c623ab
--- /dev/null
+++ b/makefu/2configs/graphite-standalone.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }:
+
+# graphite-web on port 8080
+# carbon cache on port 2003 (tcp/udp)
+with lib;
+{
+ imports = [ ];
+ services.graphite = {
+ web = {
+ enable = true;
+ host = "0.0.0.0";
+ };
+ carbon = {
+ enableCache = true;
+ # save disk usage by restricting to 1 bulk update per second
+ config = ''
+ [cache]
+ MAX_CACHE_SIZE = inf
+ MAX_UPDATES_PER_SECOND = 1
+ MAX_CREATES_PER_MINUTE = 50
+ '';
+ storageSchemas = ''
+ [carbon]
+ pattern = ^carbon\.
+ retentions = 60:90d
+
+ [default]
+ pattern = .*
+ retentions = 60s:30d,300s:1y
+ '';
+ };
+ };
+}