summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/git/gitlab-runner-shackspace.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/git/gitlab-runner-shackspace.nix')
-rw-r--r--makefu/2configs/git/gitlab-runner-shackspace.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/makefu/2configs/git/gitlab-runner-shackspace.nix b/makefu/2configs/git/gitlab-runner-shackspace.nix
deleted file mode 100644
index a5a1247b..00000000
--- a/makefu/2configs/git/gitlab-runner-shackspace.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ config, ... }:
-let
- url = "https://git.shackspace.de/";
- # generate token from CI-token via:
- ## gitlab-runner register
- token = import <secrets/shackspace-gitlab-ci-token.nix> ;
-in {
- virtualisation.docker.enable = true;
- services.gitlab-runner = {
- enable = true;
- gracefulTimeout = "120min";
- # configFile = "/var/src/secrets/runner.toml";
- configOptions = {
- concurrent = 2;
- runners = [{
- name = "nix-krebs-1.11";
- inherit token url;
- executor = "docker";
- builds_dir = "";
- docker = {
- host = "";
- image = "nixos/nix:1.11";
- privileged = false;
- disable_cache = false;
- volumes = ["/cache"];
- shm_size = 0;
- };
- cache = {};
- }];
- };
- };
-}