summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/fs/vm-single-partition.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/fs/vm-single-partition.nix')
-rw-r--r--makefu/2configs/fs/vm-single-partition.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/fs/vm-single-partition.nix b/makefu/2configs/fs/vm-single-partition.nix
new file mode 100644
index 00000000..78a5e717
--- /dev/null
+++ b/makefu/2configs/fs/vm-single-partition.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+# vda1 ext4 (label nixos) -> only root partition
+with lib;
+{
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+
+}