summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/scrape/selenium.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/scrape/selenium.nix')
-rw-r--r--makefu/2configs/deployment/scrape/selenium.nix65
1 files changed, 0 insertions, 65 deletions
diff --git a/makefu/2configs/deployment/scrape/selenium.nix b/makefu/2configs/deployment/scrape/selenium.nix
deleted file mode 100644
index d700259b..00000000
--- a/makefu/2configs/deployment/scrape/selenium.nix
+++ /dev/null
@@ -1,65 +0,0 @@
-{config, pkgs, lib, ...}:
-with <stockholm/lib>;
-let
- selenium-pw = <secrets/selenium-vncpasswd>;
-in {
- services.jenkinsSlave.enable = true;
- users.users.selenium = {
- uid = genid "selenium";
- extraGroups = [ "plugdev" ];
- };
-
- fonts.enableFontDir = true;
-
- # networking.firewall.allowedTCPPorts = [ 5910 ];
-
- systemd.services.selenium-X11 =
- {
- description = "X11 vnc for selenium";
- wantedBy = [ "multi-user.target" ];
- path = [ pkgs.xorg.xorgserver pkgs.tightvnc pkgs.dwm ];
- environment =
- {
- DISPLAY = ":10";
- };
- script = ''
- set -ex
- [ -e /tmp/.X10-lock ] && ( set +e ; chmod u+w /tmp/.X10-lock ; rm /tmp/.X10-lock )
- [ -e /tmp/.X11-unix/X10 ] && ( set +e ; chmod u+w /tmp/.X11-unix/X10 ; rm /tmp/.X11-unix/X10 )
- mkdir -p ~/.vnc
- cp -f ${selenium-pw} ~/.vnc/passwd
- chmod go-rwx ~/.vnc/passwd
- echo > ~/.vnc/xstartup
- chmod u+x ~/.vnc/xstartup
- vncserver $DISPLAY -geometry 1280x1024 -depth 24 -name jenkins -ac
- dwm
- '';
- preStop = ''
- vncserver -kill $DISPLAY
- '';
- serviceConfig = {
- User = "selenium";
- };
- };
-
- systemd.services.selenium-server =
- {
- description = "selenium-server";
- wantedBy = [ "multi-user.target" ];
- requires = [ "selenium-X11.service" ];
- path = [ pkgs.chromium
- pkgs.firefoxWrapper ];
- environment =
- {
- DISPLAY = ":10";
- };
- script = ''
- ${pkgs.selenium-server-standalone}/bin/selenium-server -Dwebdriver.enable.native.events=1
- '';
- serviceConfig = {
- User = "selenium";
- };
- };
-
-
-}