summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/rss/ratt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/rss/ratt.nix')
-rw-r--r--makefu/2configs/deployment/rss/ratt.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/makefu/2configs/deployment/rss/ratt.nix b/makefu/2configs/deployment/rss/ratt.nix
deleted file mode 100644
index 2e7ecb45..00000000
--- a/makefu/2configs/deployment/rss/ratt.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ pkgs, lib, config, ... }:
-let
- fqdn = "rss.euer.krebsco.de";
- ratt-path = "/var/lib/ratt/";
- out-path = "${ratt-path}/all.xml";
-in {
- systemd.tmpfiles.rules = ["d ${ratt-path} 0750 nginx nginx - -" ];
- systemd.services.run-ratt = {
- enable = true;
- path = with pkgs; [ ratt xmlstarlet ];
- script = builtins.readFile ./ratt-hourly.sh;
- scriptArgs = "${./urls} ${out-path}";
-
- preStart = "install -v -m750 ${./ebk.yml} ${ratt-path}/ebk.yml"; # ratt requires the config file in the cwd
- serviceConfig.User = "nginx";
- serviceConfig.WorkingDirectory= ratt-path;
- startAt = "00/3:07"; # every 3 hours, fetch latest
- };
-
- services.nginx.virtualHosts."${fqdn}" = {
- locations."=/ratt/all.xml" = {
- alias = out-path;
- };
- };
-}
-