summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/ntfysh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/ntfysh.nix')
-rw-r--r--makefu/2configs/deployment/ntfysh.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/makefu/2configs/deployment/ntfysh.nix b/makefu/2configs/deployment/ntfysh.nix
deleted file mode 100644
index 1a3311d9..00000000
--- a/makefu/2configs/deployment/ntfysh.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ lib, config, ... }:
-let
- web-port = 19455;
- hostn = "ntfy.euer.krebsco.de";
- internal-ip = config.krebs.build.host.nets.retiolum.ip4.addr;
-in
-{
- services.ntfy-sh = {
- enable = true;
- settings = {
- listen-http = "127.0.0.1:${toString web-port}";
- auth-file = "/var/lib/ntfy-sh/user.db";
- auth-default-access = "deny-all";
- behind-proxy = true;
- attachment-cache-dir = "/media/cloud/ntfy-sh/attachments";
- attachment-file-size-limit = "500m";
- attachment-total-size-limit = "100g";
- base-url = "https://ntfy.euer.krebsco.de";
- attachment-expiry-duration = "48h";
- };
- };
-
- systemd.services.ntfy-sh.serviceConfig = {
- StateDirectory = "ntfy-sh";
- SupplementaryGroups = [ "download" ];
- };
-
- services.nginx = {
- enable = lib.mkDefault true;
- virtualHosts."${hostn}" = {
- forceSSL = true;
- enableACME = true;
-
- locations."/" = {
- proxyPass = "http://localhost:${toString web-port}/";
- proxyWebsockets = true;
- recommendedProxySettings = true;
- };
- };
- };
-}