summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/mycube.connector.one.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/mycube.connector.one.nix')
-rw-r--r--makefu/2configs/deployment/mycube.connector.one.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/makefu/2configs/deployment/mycube.connector.one.nix b/makefu/2configs/deployment/mycube.connector.one.nix
deleted file mode 100644
index aa9ff514..00000000
--- a/makefu/2configs/deployment/mycube.connector.one.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{ config, lib, pkgs, ... }:
-# more than just nginx config but not enough to become a module
-let
- hostname = config.krebs.build.host.name;
- external-ip = config.krebs.build.host.nets.internet.ip4.addr;
- wsgi-sock = "${config.services.uwsgi.runDir}/uwsgi.sock";
-in {
- services.redis = { enable = true; };
- systemd.services.redis.serviceConfig.LimitNOFILE=65536;
-
- services.uwsgi = {
- enable = true;
- user = "nginx";
- plugins = [ "python2" ];
- instance = {
- type = "emperor";
- vassals = {
- mycube-flask = {
- type = "normal";
- pythonPackages = self: with self; [ pkgs.mycube-flask ];
- socket = wsgi-sock;
- };
- };
- };
- };
-
- services.nginx = {
- enable = lib.mkDefault true;
- virtualHosts."mybox.connector.one" = {
- locations = {
- "/".extraConfig = ''
- uwsgi_pass unix://${wsgi-sock};
- uwsgi_param UWSGI_CHDIR ${pkgs.mycube-flask}/${pkgs.python.sitePackages};
- uwsgi_param UWSGI_MODULE mycube.websrv;
- uwsgi_param UWSGI_CALLABLE app;
-
- include ${pkgs.nginx}/conf/uwsgi_params;
- '';
- };
- };
- };
-}