summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/hound/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/hound/default.nix')
-rw-r--r--makefu/2configs/deployment/hound/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/makefu/2configs/deployment/hound/default.nix b/makefu/2configs/deployment/hound/default.nix
index 9e8f8889..0cfb5cde 100644
--- a/makefu/2configs/deployment/hound/default.nix
+++ b/makefu/2configs/deployment/hound/default.nix
@@ -1,6 +1,10 @@
{ config, pkgs, ... }:
{
- services.nginx.virtualHosts."wikisearch.krebsco.de".locations."/".proxyPass = "http://localhost:6080";
+ services.nginx.virtualHosts."wikisearch.krebsco.de" = {
+ forceSSL = true;
+ enableACME = true;
+ locations."/".proxyPass = "http://localhost:6080";
+ };
services.hound = {
enable = true;
listen = "127.0.0.1:6080";