summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/dirctator.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/dirctator.nix')
-rw-r--r--makefu/2configs/deployment/dirctator.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/makefu/2configs/deployment/dirctator.nix b/makefu/2configs/deployment/dirctator.nix
deleted file mode 100644
index 7303bb41..00000000
--- a/makefu/2configs/deployment/dirctator.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ pkgs, lib, ... }:
-
-with lib;
-let
- port = 18872;
- runit = pkgs.writeDash "runit" ''
- set -xeuf
- export PULSE_COOKIE=/var/run/pulse/.config/pulse/cookie
- echo "$@" | sed 's/^dirctator://' | ${pkgs.espeak}/bin/espeak -v mb-de7 2>&1 | tee -a /tmp/speak
- '';
-in {
- services.logstash = {
- package = pkgs.logstash5;
- enable = true;
- inputConfig = ''
- irc {
- channels => [ "#krebs", "#afra" ]
- host => "irc.hackint.org"
- nick => "dirctator"
- }
- '';
- filterConfig = ''
- '';
- outputConfig = ''
- stdout { codec => rubydebug }
- exec { command => "${runit} '%{message}" }
- '';
- extraSettings = ''
- path.plugins: [ "${pkgs.logstash-output-exec}" ]
- '';
- ## NameError: `@path.plugins' is not allowable as an instance variable name
- # plugins = [ pkgs.logstash-output-exec ];
- };
-}