summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/bureautomation/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/bureautomation/default.nix')
-rw-r--r--makefu/2configs/deployment/bureautomation/default.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/makefu/2configs/deployment/bureautomation/default.nix b/makefu/2configs/deployment/bureautomation/default.nix
deleted file mode 100644
index 3897537e..00000000
--- a/makefu/2configs/deployment/bureautomation/default.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ pkgs, lib, ... }:
-
-with lib;
-let
- port = 3001;
- runit = pkgs.writeDash "runit" ''
- set -xeuf
- PATH=${pkgs.curl}/bin:${pkgs.coreutils}/bin
- name=''${1?must provide name as first arg}
- state=''${2?must provide state as second arg}
- # val=''${3?must provide val as third arg}
-
- # we ignore non-alerting events
- test $state = alerting || exit 0
-
- echo $name - $state
- curl 'http://bauarbeiterlampe/ay?o=1'
- sleep 5
- curl 'http://bauarbeiterlampe/ay?o=1'
- '';
-in {
- services.logstash = {
- package = pkgs.logstash5;
- enable = true;
- inputConfig = ''
- http {
- port => ${toString port}
- host => "127.0.0.1"
- }
- '';
- filterConfig = ''
- '';
- outputConfig = ''
- stdout { codec => json }
- exec { command => "${runit} '%{ruleName}' '%{state}'" }
- '';
- extraSettings = ''
- path.plugins: [ "${pkgs.logstash-output-exec}" ]
- '';
- };
-}