summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/boot-euer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/boot-euer.nix')
-rw-r--r--makefu/2configs/deployment/boot-euer.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/makefu/2configs/deployment/boot-euer.nix b/makefu/2configs/deployment/boot-euer.nix
deleted file mode 100644
index f890ea7a..00000000
--- a/makefu/2configs/deployment/boot-euer.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ config, lib, pkgs, ... }:
-# more than just nginx config but not enough to become a module
-with import <stockholm/lib>;
-let
- hostname = config.krebs.build.host.name;
- bootscript = pkgs.writeTextDir "runit" ''
- set -euf
- cd /root
- mkdir -p .ssh
- echo "${config.krebs.users.makefu.pubkey}" > .ssh/authorized_keys
- chmod 700 -R .ssh
- systemctl restart sshd
- '';
-in {
-
- services.nginx = {
- enable = mkDefault true;
- virtualHosts."boot.euer.krebsco.de" = {
- forceSSL = true;
- enableACME = true;
- locations."/" = {
- root = bootscript;
- index = "runit";
- };
- };
- };
-}