summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/switch/tasmota_switch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bureautomation/switch/tasmota_switch.nix')
-rw-r--r--makefu/2configs/bureautomation/switch/tasmota_switch.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/makefu/2configs/bureautomation/switch/tasmota_switch.nix b/makefu/2configs/bureautomation/switch/tasmota_switch.nix
deleted file mode 100644
index 6c5f6b8a..00000000
--- a/makefu/2configs/bureautomation/switch/tasmota_switch.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-let
- tasmota_plug = name: topic:
- { platform = "mqtt";
- inherit name;
- state_topic = "/bam/${topic}/tele/STATE";
- value_template = "{{ value_json.POWER }}";
- command_topic = "/bam/${topic}/cmnd/POWER";
- availability_topic = "/bam/${topic}/tele/LWT";
- payload_on= "ON";
- payload_off= "OFF";
- payload_available= "Online";
- payload_not_available= "Offline";
- retain = false;
- qos = 1;
- };
-in {
- services.home-assistant.config.switch =
- [
- (tasmota_plug "Bauarbeiterlampe" "plug")
- (tasmota_plug "Blitzdings" "plug2")
- (tasmota_plug "Fernseher" "plug3")
- (tasmota_plug "Feuer" "plug4")
- (tasmota_plug "Blaulicht" "plug5")
- ];
-}