summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/office-radio/webserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bureautomation/office-radio/webserver.nix')
-rw-r--r--makefu/2configs/bureautomation/office-radio/webserver.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/makefu/2configs/bureautomation/office-radio/webserver.nix b/makefu/2configs/bureautomation/office-radio/webserver.nix
deleted file mode 100644
index e2fc6d9e..00000000
--- a/makefu/2configs/bureautomation/office-radio/webserver.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ pkgs, ... }:
-let
- mpds = import ./mpdconfig.nix;
- pkg = pkgs.office-radio;
-in {
- systemd.services.office-radio-appsrv = {
- after = [ "network.target" ];
- description = "Office Radio Appserver";
- wantedBy = [ "multi-user.target" ];
- serviceConfig = {
- ExecStart = "${pkg}/bin/office-radio";
- DynamicUser = true;
- ProtectSystem = true;
- NoNewPrivileges = true;
- ProtectKernelTunables = true;
- ProtectControlGroups = true;
- ProtectKernelModules = true;
- RestrictAddressFamilies = "AF_INET AF_INET6 AF_UNIX AF_NETLINK";
- RestrictNamespaces = true;
- Restart = "always";
- };
- };
- systemd.services.office-radio-stopper = {
- after = [ "network.target" ];
- description = "Office Radio Script to stop idle streams";
- wantedBy = [ "multi-user.target" ];
- serviceConfig = {
- ExecStart = "${pkg}/bin/stop-idle-streams";
- DynamicUser = true;
- ProtectSystem = true;
- NoNewPrivileges = true;
- ProtectKernelTunables = true;
- ProtectControlGroups = true;
- ProtectKernelModules = true;
- RestrictAddressFamilies = "AF_INET AF_INET6 AF_UNIX AF_NETLINK";
- RestrictNamespaces = true;
- Restart = "always";
- };
- };
-}