summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/multi/daily-standup.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bureautomation/multi/daily-standup.nix')
-rw-r--r--makefu/2configs/bureautomation/multi/daily-standup.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/multi/daily-standup.nix b/makefu/2configs/bureautomation/multi/daily-standup.nix
new file mode 100644
index 00000000..f5bd85b9
--- /dev/null
+++ b/makefu/2configs/bureautomation/multi/daily-standup.nix
@@ -0,0 +1,54 @@
+{ lib }:
+let
+ random_daily_text = ''{{ [
+ "Es ist so weit, es ist Standup Zeit!",
+ "Zehn Uhr Fünfunddreissig ist genau die richtige Zeit für ein Standup!",
+ "Hat jeder seine Hausaufgaben gemacht? Bitte einmal aufstehen und den Zettel nach rechts geben",
+ "Aufstehen zum Appell, es wird die Anwesenheit kontrolliert!",
+ "Hallo Kinder, wisst ihr welche Zeit es ist??? ... Genau! ... Standup Zeit!",
+ "Morgens, halb elf in Deutschland - das Standupchen" ] | random }}'';
+
+in {
+ script =
+ { "random_daily" = {
+ alias = "Random Daily Introduction";
+
+ sequence = [
+ { service = "media_player.play_media";
+ data = {
+ entity_id = "media_player.mpd";
+ media_content_type = "playlist";
+ media_content_id = "ansage";
+ };
+ }
+ { delay.seconds = 5; }
+ { service = "tts.google_say";
+ entity_id = "media_player.mpd";
+ data_template = {
+ message = random_daily_text;
+ language = "de";
+ };
+ }
+ ];
+ };
+ };
+ automation = [
+ {
+ alias = "Daily Standup";
+ trigger = {
+ platform = "time";
+ at = "10:35:00";
+ };
+ action =
+ [
+ { service = "homeassistant.turn_on";
+ entity_id = [
+ "script.blitz_10s"
+ "script.random_daily"
+ ];
+ }
+ ];
+
+ }
+ ];
+}