summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/kalauerbot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bureautomation/kalauerbot.nix')
-rw-r--r--makefu/2configs/bureautomation/kalauerbot.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/makefu/2configs/bureautomation/kalauerbot.nix b/makefu/2configs/bureautomation/kalauerbot.nix
deleted file mode 100644
index aa66e30b..00000000
--- a/makefu/2configs/bureautomation/kalauerbot.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ config, lib, pkgs, ... }:
-let
- oofdir = fetchTarball {
- url = "https://o.euer.krebsco.de/s/AZn9QPLGFZeDfNq/download";
- sha256 = "1wa59rkgffql6hbiw9vv0zh35wx9x1cp4bnwicprbd0kdxj75miz";
- };
-
-in
-{
- systemd.services.kalauerbot = {
- description = "Kalauerbot";
- after = [ "network-online.target" ];
- wantedBy = [ "multi-user.target" ];
- environment = import <secrets/bureautomation/citadel.nix> // {
- "KALAUER_OOFDIR" = oofdir;
- };
- serviceConfig = {
- DynamicUser = true;
- StateDirectory = "kalauerbot";
- WorkingDirectory = "/var/lib/kalauerbot";
- ExecStart = "${pkgs.kalauerbot}/bin/kalauerbot";
- PrivateTmp = true;
-
- Restart = "always";
- RuntimeMaxSec = "12h";
- };
- };
-}