summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bluetooth-mpd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bluetooth-mpd.nix')
-rw-r--r--makefu/2configs/bluetooth-mpd.nix73
1 files changed, 0 insertions, 73 deletions
diff --git a/makefu/2configs/bluetooth-mpd.nix b/makefu/2configs/bluetooth-mpd.nix
deleted file mode 100644
index e007b607..00000000
--- a/makefu/2configs/bluetooth-mpd.nix
+++ /dev/null
@@ -1,73 +0,0 @@
-{ pkgs, config, lib, ... }:
-
-let
- cfg = config.makefu.mpd;
-in {
- options.makefu.mpd.musicDirectory = lib.mkOption {
- description = "music Directory";
- default = "/data/music";
- type = lib.types.str;
- };
- config = {
- services.mpd = {
- enable = true;
- inherit (cfg) musicDirectory;
- network.listenAddress = "0.0.0.0";
- extraConfig = ''
- audio_output {
- type "pulse"
- name "Local MPD"
- server "127.0.0.1"
- }
- '';
- };
- # open because of truestedInterfaces
- # networking.firewall.allowedTCPPorts = [ 6600 4713 ];
- services.samba.shares.music = {
- path = cfg.musicDirectory;
- "read only" = "no";
- browseable = "yes";
- "guest ok" = "yes";
- };
-
- sound.enable = true;
- hardware.pulseaudio = {
- enable = true;
- package = pkgs.pulseaudioFull;
- # systemWide = true;
- support32Bit = true;
- zeroconf.discovery.enable = true;
- zeroconf.publish.enable = true;
- tcp = {
- enable = true;
- # PULSE_SERVER=192.168.1.11 pavucontrol
- anonymousClients.allowAll = true;
- anonymousClients.allowedIpRanges = [ "127.0.0.1" "192.168.0.0/16" ];
- };
- configFile = pkgs.writeText "default.pa" ''
- load-module module-udev-detect
- load-module module-bluetooth-policy
- load-module module-bluetooth-discover
- load-module module-native-protocol-unix auth-anonymous=1
- load-module module-always-sink
- load-module module-console-kit
- load-module module-systemd-login
- load-module module-intended-roles
- load-module module-position-event-sounds
- load-module module-filter-heuristics
- load-module module-filter-apply
- load-module module-switch-on-connect
- load-module module-equalizer-sink
- load-module module-dbus-protocol
- #load-module module-bluez5-device
- #load-module module-bluez5-discover
- '';
- };
- # connect via https://nixos.wiki/wiki/Bluetooth#Using_Bluetooth_headsets_with_PulseAudio
- hardware.bluetooth.enable = true;
- # environment.etc."bluetooth/audio.conf".text = ''
- # [General]
- # Enable = Source,Sink,Media,Socket
- # '';
- };
-}