summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bitwarden.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bitwarden.nix')
-rw-r--r--makefu/2configs/bitwarden.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/makefu/2configs/bitwarden.nix b/makefu/2configs/bitwarden.nix
new file mode 100644
index 00000000..7e317e59
--- /dev/null
+++ b/makefu/2configs/bitwarden.nix
@@ -0,0 +1,46 @@
+{ pkgs, ... }:
+let
+ port = 8812;
+in {
+ services.bitwarden_rs = {
+ enable = true;
+ dbBackend = "postgresql";
+ config.signups_allowed = false;
+ config.rocketPort = port;
+ config.domain = "https://bw.euer.krebsco.de";
+ #config.databaseUrl = "postgresql://bitwardenuser:${dbPassword}@localhost/bitwarden";
+ config.databaseUrl = "postgresql:///bitwarden";
+ config.websocket_enabled = true;
+ };
+
+ systemd.services.bitwarden_rs.after = [ "postgresql.service" ];
+
+ services.postgresql = {
+ enable = true;
+ ensureDatabases = [ "bitwarden" ];
+ ensureUsers = [ { name = "bitwarden_rs"; ensurePermissions."DATABASE bitwarden" = "ALL PRIVILEGES"; } ];
+ #initialScript = pkgs.writeText "postgresql-init.sql" ''
+ # CREATE DATABASE bitwarden;
+ # CREATE USER bitwardenuser WITH PASSWORD '${dbPassword}';
+ # GRANT ALL PRIVILEGES ON DATABASE bitwarden TO bitwardenuser;
+ #'';
+ };
+
+ services.nginx.virtualHosts."bw.euer.krebsco.de" ={
+ forceSSL = true;
+ enableACME = true;
+
+ locations."/" = {
+ proxyPass = "http://localhost:8812";
+ proxyWebsockets = true;
+ };
+ locations."/notifications/hub" = {
+ proxyPass = "http://localhost:3012";
+ proxyWebsockets = true;
+ };
+ locations."/notifications/hub/negotiate" = {
+ proxyPass = "http://localhost:8812";
+ proxyWebsockets = true;
+ };
+ };
+}