summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/backup/state.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/backup/state.nix')
-rw-r--r--makefu/2configs/backup/state.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/makefu/2configs/backup/state.nix b/makefu/2configs/backup/state.nix
deleted file mode 100644
index 1143708b..00000000
--- a/makefu/2configs/backup/state.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ config, ... }:
-# back up all state
-let
- sec = toString <secrets>;
- sshkey = sec + "/borg.priv";
- phrase = sec + "/borg.pw";
-in
-{
- services.borgbackup.jobs.state = {
- repo = "borg-${config.krebs.build.host.name}@backup.makefu.r:.";
- paths = config.state;
- encryption = {
- mode = "repokey";
- passCommand = "cat ${phrase}";
- };
- environment.BORG_RSH = "ssh -i ${sshkey}";
- prune.keep =
- { daily = 7;
- weekly = 4;
- monthly = -1; # Keep at least one archive for each month
- };
- compression = "auto,lzma";
- startAt = "daily";
- };
-}