summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/backup/server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/backup/server.nix')
-rw-r--r--makefu/2configs/backup/server.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/makefu/2configs/backup/server.nix b/makefu/2configs/backup/server.nix
deleted file mode 100644
index 26e53b8c..00000000
--- a/makefu/2configs/backup/server.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-{lib,config, ... }:
-let
- hosts = lib.mapAttrsToList (f: _: lib.removeSuffix ".pub" f) (builtins.readDir ./ssh );
-in {
- # TODO: for all enabled machines
- options = {
- makefu.backup.server.repo = lib.mkOption {
- type = lib.types.str;
- default = "/var/lib/borgbackup";
- };
- };
- config = {
- services.borgbackup.repos = lib.genAttrs hosts (host: {
- authorizedKeys = [ (builtins.readFile (./ssh + "/${host}.pub") ) ];
- path = "${config.makefu.backup.server.repo}/${host}";
- user = "borg-${host}";
- }) ;
- };
-}