summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/Reaktor/shack-correct.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/Reaktor/shack-correct.nix')
-rw-r--r--makefu/2configs/Reaktor/shack-correct.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/Reaktor/shack-correct.nix b/makefu/2configs/Reaktor/shack-correct.nix
new file mode 100644
index 00000000..8f30807f
--- /dev/null
+++ b/makefu/2configs/Reaktor/shack-correct.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+with pkgs;
+let
+ script = pkgs.substituteAll ( {
+ name="shack-correct";
+ isExecutable=true;
+ dir = "";
+ src = ./shack-correct.sh;
+ });
+in {
+ krebs.Reaktor.extraConfig = ''
+ public_commands.insert(0,{
+ 'capname' : "shack-correct",
+ 'pattern' : '^(?P<args>.*Shack.*)$$',
+ 'argv' : ["${script}"],
+ 'env' : { }})
+ '';
+}
+