summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo/hw/omo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/omo/hw/omo.nix')
-rw-r--r--makefu/1systems/omo/hw/omo.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/makefu/1systems/omo/hw/omo.nix b/makefu/1systems/omo/hw/omo.nix
index 87af2a31..586ad98c 100644
--- a/makefu/1systems/omo/hw/omo.nix
+++ b/makefu/1systems/omo/hw/omo.nix
@@ -80,18 +80,19 @@ in {
boot = {
initrd.luks = {
devices = let
- usbkey = name: device: {
- inherit name device keyFile;
+ usbkey = device: {
+ inherit device keyFile;
keyFileSize = 4096;
allowDiscards = true;
};
- in [
- (usbkey "luksroot" rootPartition)
- (usbkey "crypt0" cryptDisk0)
- (usbkey "crypt1" cryptDisk1)
- (usbkey "crypt2" cryptDisk2)
- (usbkey "crypt3" cryptDisk3)
- ];
+ in
+ {
+ luksroot = usbkey rootPartition;
+ crypt0 = usbkey cryptDisk0;
+ crypt1 = usbkey cryptDisk1;
+ crypt2 = usbkey cryptDisk2;
+ crypt3 = usbkey cryptDisk3;
+ };
};
loader.grub.device = lib.mkForce rootDisk;