summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/filepimp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/filepimp.nix')
-rw-r--r--makefu/1systems/filepimp.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/makefu/1systems/filepimp.nix b/makefu/1systems/filepimp.nix
new file mode 100644
index 00000000..fabecec8
--- /dev/null
+++ b/makefu/1systems/filepimp.nix
@@ -0,0 +1,41 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ../2configs/base.nix
+ ../2configs/fs/vm-single-partition.nix
+ ../2configs/fs/single-partition-ext4.nix
+ ../2configs/tinc-basic-retiolum.nix
+ ../2configs/base-sources.nix
+ ];
+ krebs.build.host = config.krebs.hosts.filepimp;
+ krebs.build.user = config.krebs.users.makefu;
+ krebs.build.target = "root@filepimp";
+
+ # AMD N54L
+ boot = {
+ loader.grub.device = "/dev/sda";
+
+ initrd.availableKernelModules = [
+ "usb_storage"
+ "ahci"
+ "xhci_hcd"
+ "ata_piix"
+ "uhci_hcd"
+ "ehci_pci"
+ ];
+
+ kernelModules = [ ];
+ extraModulePackages = [ ];
+ };
+
+ hardware.enableAllFirmware = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+ networking.firewall.allowPing = true;
+}