summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/drop/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/drop/config.nix')
-rw-r--r--makefu/1systems/drop/config.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/makefu/1systems/drop/config.nix b/makefu/1systems/drop/config.nix
deleted file mode 100644
index 2757db8c..00000000
--- a/makefu/1systems/drop/config.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ config, pkgs, ... }:
-let
- external-ip = "45.55.145.62";
- default-gw = "45.55.128.1";
- prefixLength = 18;
-in {
- imports = [
- <stockholm/makefu>
- <stockholm/makefu/2configs/hw/CAC.nix>
- <stockholm/makefu/2configs/save-diskspace.nix>
- <stockholm/makefu/2configs/torrent.nix>
- ];
- krebs = {
- enable = true;
- tinc.retiolum.enable = true;
- build.host = config.krebs.hosts.drop;
- };
-
- boot.loader.grub.device = "/dev/vda";
- boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "ehci_pci" "virtio_pci" "virtio_blk" "virtio_net" "virtio_scsi" ];
- fileSystems."/" = {
- device = "/dev/vda1";
- fsType = "ext4";
- };
-
- networking = {
- firewall = {
- allowPing = true;
- logRefusedConnections = false;
- allowedTCPPorts = [ ];
- allowedUDPPorts = [ 655 ];
- };
- interfaces.enp0s3.ipv4.addresses = [{
- address = external-ip;
- inherit prefixLength;
- }];
- defaultGateway = default-gw;
- nameservers = [ "8.8.8.8" ];
- };
-}