summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 66b01fd1..1eb4d947 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -238,7 +238,7 @@ rec {
secret-file = submodule ({ config, ... }: {
options = {
name = mkOption {
- type = filename;
+ type = pathname;
default = config._module.args.name;
};
path = mkOption {
@@ -257,8 +257,8 @@ rec {
default = "root";
};
service = mkOption {
- type = filename;
- default = "secret.service";
+ type = systemd.unit-name;
+ default = "secret-${lib.systemd.encodeName config.name}.service";
};
source-path = mkOption {
type = str;