summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 9ae92ea7..1cf2d96c 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -255,6 +255,14 @@ rec {
default = null;
type = nullOr source-types.pass;
};
+ pipe = mkOption {
+ apply = x:
+ if absolute-pathname.check x
+ then { command = x; }
+ else x;
+ default = null;
+ type = nullOr (either absolute-pathname source-types.pipe);
+ };
symlink = mkOption {
type = nullOr (either pathname source-types.symlink);
default = null;
@@ -294,6 +302,13 @@ rec {
};
};
};
+ pipe = submodule {
+ options = {
+ command = mkOption {
+ type = absolute-pathname;
+ };
+ };
+ };
symlink = submodule {
options = {
target = mkOption {