summaryrefslogtreecommitdiffstats
path: root/lib/eval-source.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/eval-source.nix')
-rw-r--r--lib/eval-source.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/lib/eval-source.nix b/lib/eval-source.nix
index de5f0b43..468fc92d 100644
--- a/lib/eval-source.nix
+++ b/lib/eval-source.nix
@@ -3,13 +3,11 @@ let
eval = _file: source: evalModules {
modules = singleton {
inherit _file;
+ imports = map (source: { inherit source; }) (toList source);
options.source = mkOption {
type = types.attrsOf types.source;
default = {};
};
- config = {
- inherit source;
- };
};
};
in