summaryrefslogtreecommitdiffstats
path: root/lass/krops.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/krops.nix')
-rw-r--r--lass/krops.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/lass/krops.nix b/lass/krops.nix
index da5933df..5927b006 100644
--- a/lass/krops.nix
+++ b/lass/krops.nix
@@ -10,11 +10,15 @@
(krebs-source { test = test; })
{
nixos-config.symlink = "stockholm/lass/1systems/${name}/physical.nix";
+ nixpkgs-unstable.git = {
+ url = "https://github.com/nixos/nixpkgs-channels";
+ ref = (lib.importJSON ../krebs/nixpkgs-unstable.json).rev;
+ };
secrets = if test then {
file = toString ./2configs/tests/dummy-secrets;
} else {
pass = {
- dir = "${lib.getEnv "HOME"}/.password-store";
+ dir = "${lib.getEnv "HOME"}/sync/pwstore";
name = "hosts/${name}";
};
};