summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/untilport/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/5pkgs/untilport/default.nix')
-rw-r--r--lass/5pkgs/untilport/default.nix18
1 files changed, 0 insertions, 18 deletions
diff --git a/lass/5pkgs/untilport/default.nix b/lass/5pkgs/untilport/default.nix
deleted file mode 100644
index 61bcc2b8..00000000
--- a/lass/5pkgs/untilport/default.nix
+++ /dev/null
@@ -1,18 +0,0 @@
-{ pkgs, ... }:
-
-pkgs.writeDashBin "untilport" ''
- set -euf
-
- usage() {
- echo 'untiport $target $port'
- echo 'Sleeps until the destinated port is reachable.'
- echo 'ex: untilport google.de 80 && echo "google is now reachable"'
- }
-
-
- if [ $# -ne 2 ]; then
- usage
- else
- until ${pkgs.netcat-openbsd}/bin/nc -z "$@"; do sleep 1; done
- fi
-''