summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/sxiv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/5pkgs/sxiv/default.nix')
-rw-r--r--lass/5pkgs/sxiv/default.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/lass/5pkgs/sxiv/default.nix b/lass/5pkgs/sxiv/default.nix
deleted file mode 100644
index 04fc1c3f..00000000
--- a/lass/5pkgs/sxiv/default.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ nsxiv, writers }:
-
-writers.writeDashBin "sxiv" ''
- set -efu
- tmpfile="''${TMPDIR:-/tmp}/nsxiv_pipe_$$"
- trap 'rm -f -- $tmpfile' EXIT
-
- if [ "$#" -eq 0 ]; then
- if [ -t 0 ]; then
- echo "sxiv: No arguments provided" >&2; exit 1
- else
- # Consume stdin and put it in the temporal file
- cat > "$tmpfile"
- fi
- fi
-
- for arg in "$@"; do
- # if it's a pipe then drain it to $tmpfile
- [ -p "$arg" ] && cat "$arg" > "$tmpfile"
- done
-
- if [ -s "$tmpfile" ]; then
- ${nsxiv}/bin/nsxiv -q "$@" "$tmpfile" # -q to silence warnings
- else
- ${nsxiv}/bin/nsxiv "$@" # fallback
- fi
-''