summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/mpv-poll/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/5pkgs/mpv-poll/default.nix')
-rw-r--r--lass/5pkgs/mpv-poll/default.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/lass/5pkgs/mpv-poll/default.nix b/lass/5pkgs/mpv-poll/default.nix
deleted file mode 100644
index ee191843..00000000
--- a/lass/5pkgs/mpv-poll/default.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ pkgs, ... }:
-
-pkgs.writeScriptBin "mpv-poll" ''
- #! ${pkgs.bash}/bin/bash
-
- pl=$1
- hist=''${HISTORY:-"./mpv_history"}
- mpv_options=''${MPV_OPTIONS:-""}
-
- lastYT=""
-
- play_video () {
- toPlay=$1
- echo $toPlay >> $hist
- mpv $mpv_options $toPlay
- }
-
- if ! [ -e $hist ]; then
- touch $hist
- fi
-
- while :
- do
- if [ -s $pl ]; then
- toPlay=$(head -1 $pl)
- sed -i '1d' $pl
- if $(echo $toPlay | grep -Eq 'https?://(www.)?youtube.com/watch'); then
- lastYT=$toPlay
- fi
- play_video $toPlay
- else
- if [ -n "$lastYT" ]; then
- next=$(yt-next $lastYT)
- lastYT=$next
- play_video $next
- fi
- sleep 1
- fi
- done
-''