summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/graphml2json/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/5pkgs/graphml2json/default.nix')
-rw-r--r--lass/5pkgs/graphml2json/default.nix12
1 files changed, 0 insertions, 12 deletions
diff --git a/lass/5pkgs/graphml2json/default.nix b/lass/5pkgs/graphml2json/default.nix
deleted file mode 100644
index 6f06ded3..00000000
--- a/lass/5pkgs/graphml2json/default.nix
+++ /dev/null
@@ -1,12 +0,0 @@
-{ pkgs, ... }:
-pkgs.writers.writePython3Bin "graphml2json" { libraries = [ pkgs.python3Packages.networkx ]; } ''
- import networkx as nx
- import json
- import sys
-
-
- G = nx.read_graphml(sys.argv[1])
- data = nx.readwrite.json_graph.node_link_data(G)
-
- print(json.dumps(data, indent=2))
-''