summaryrefslogtreecommitdiffstats
path: root/lass/3modules/sshkeys.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/3modules/sshkeys.nix')
-rw-r--r--lass/3modules/sshkeys.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/lass/3modules/sshkeys.nix b/lass/3modules/sshkeys.nix
deleted file mode 100644
index 5f1c6066..00000000
--- a/lass/3modules/sshkeys.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ lib, ... }:
-
-with lib;
-
-{
- options = {
- sshKeys = mkOption {
- type = types.attrsOf (types.submodule (
- { config, ... }:
- {
- options = {
- pub = mkOption {
- type = types.str;
- description = "Public part of the ssh key.";
- };
-
- priv = mkOption {
- type = types.str;
- description = "Private part of the ssh key.";
- };
- };
- }));
- description = "collection of ssh-keys";
- };
- };
-}