summaryrefslogtreecommitdiffstats
path: root/lass/2configs/weechat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/weechat.nix')
-rw-r--r--lass/2configs/weechat.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/lass/2configs/weechat.nix b/lass/2configs/weechat.nix
new file mode 100644
index 00000000..cfcc1a2f
--- /dev/null
+++ b/lass/2configs/weechat.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ imports = [
+ ../3modules/per-user.nix
+ ];
+
+ lass.per-user.chat.packages = [
+ pkgs.weechat
+ pkgs.tmux
+ ];
+
+ users.extraUsers.chat = {
+ home = "/home/chat";
+ useDefaultShell = true;
+ createHome = true;
+ openssh.authorizedKeys.keys = map readFile [
+ ../../krebs/Zpubkeys/lass.ssh.pub
+ ];
+ };
+}