summaryrefslogtreecommitdiffstats
path: root/lass/2configs/steam.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/steam.nix')
-rw-r--r--lass/2configs/steam.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/lass/2configs/steam.nix b/lass/2configs/steam.nix
new file mode 100644
index 00000000..7d088fc6
--- /dev/null
+++ b/lass/2configs/steam.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, ... }:
+
+{
+
+ imports = [
+ ./games.nix
+ ];
+ #
+ # Steam stuff
+ # source: https://nixos.org/wiki/Talk:Steam
+ #
+ ##TODO: make steam module
+ hardware.opengl.driSupport32Bit = true;
+
+ nixpkgs.config.steam.java = true;
+ environment.systemPackages = with pkgs; [
+ steam
+ ];
+ networking.firewall = {
+ allowedUDPPorts = [
+ 27031
+ 27036
+ ];
+ allowedTCPPorts = [
+ 27036
+ 27037
+ ];
+ };
+
+}