summaryrefslogtreecommitdiffstats
path: root/lass/2configs/reaktor-coders.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/reaktor-coders.nix')
-rw-r--r--lass/2configs/reaktor-coders.nix56
1 files changed, 0 insertions, 56 deletions
diff --git a/lass/2configs/reaktor-coders.nix b/lass/2configs/reaktor-coders.nix
deleted file mode 100644
index 457d5b6c..00000000
--- a/lass/2configs/reaktor-coders.nix
+++ /dev/null
@@ -1,56 +0,0 @@
-{ config, lib, pkgs, ... }:
-with import <stockholm/lib>;
-
-let
- hooks = pkgs.reaktor2-plugins.hooks;
-in {
- krebs.reaktor2.coders = {
- hostname = "irc.hackint.org";
- port = "9999";
- useTLS = true;
- nick = "reaktor2|lass";
- plugins = [
- {
- plugin = "register";
- config = {
- channels = [
- "#coders"
- "#germany"
- "#panthermoderns"
- ];
- };
- }
- {
- plugin = "system";
- config = {
- workdir = config.krebs.reaktor2.coders.stateDir;
- hooks.PRIVMSG = [
- hooks.sed
- hooks.url-title
- {
- activate = "match";
- pattern = ''^!([^ ]+)(?:\s*(.*))?'';
- command = 1;
- arguments = [2];
- commands = {
- ping.filename = pkgs.writeDash "ping" ''
- exec /run/wrappers/bin/ping -q -c1 "$1" 2>&1 | tail -1
- '';
- google.filename = pkgs.writeDash "google" ''
- exec ${pkgs.ddgr}/bin/ddgr -C -n1 --json "$@" | \
- ${pkgs.jq}/bin/jq '@text "\(.[0].abstract) \(.[0].url)"'
- '';
- shrug.filename = pkgs.writeDash "shrug" ''
- exec echo '¯\_(ツ)_/¯'
- '';
- table.filename = pkgs.writeDash "table" ''
- exec echo '(╯°□°)╯ ┻━┻'
- '';
- };
- }
- ];
- };
- }
- ];
- };
-}