summaryrefslogtreecommitdiffstats
path: root/lass/2configs/muchsync.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/muchsync.nix')
-rw-r--r--lass/2configs/muchsync.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/lass/2configs/muchsync.nix b/lass/2configs/muchsync.nix
deleted file mode 100644
index b6d8c5db..00000000
--- a/lass/2configs/muchsync.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-with (import <stockholm/lib>);
-{ config, pkgs, ... }:
-
-{
- systemd.services.muchsync = let
- hosts = [
- "coaxmetal.r"
- "mors.r"
- "green.r"
- ];
- in {
- description = "sync mails";
- environment = {
- NOTMUCH_CONFIG = config.environment.variables.NOTMUCH_CONFIG;
- };
- after = [ "network.target" ];
-
- restartIfChanged = false;
-
- path = [
- pkgs.notmuch
- pkgs.openssh
- ];
-
- startAt = "*:*"; # run every minute
- serviceConfig = {
- User = "lass";
- Type = "oneshot";
- ExecStart = pkgs.writeDash "sync-mails" ''
- set -euf
-
- /run/current-system/sw/bin/nm-tag-init 2>/dev/null
- ${concatMapStringsSep "\n" (host: ''
- echo syncing ${host}:
- ${pkgs.muchsync}/bin/muchsync -s 'ssh -CTaxq -o ConnectTimeout=4' --nonew lass@${host} || :
- '') hosts}
- '';
- };
- };
-}