summaryrefslogtreecommitdiffstats
path: root/lass/2configs/matrix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/matrix.nix')
-rw-r--r--lass/2configs/matrix.nix62
1 files changed, 0 insertions, 62 deletions
diff --git a/lass/2configs/matrix.nix b/lass/2configs/matrix.nix
deleted file mode 100644
index 7c4b645f..00000000
--- a/lass/2configs/matrix.nix
+++ /dev/null
@@ -1,62 +0,0 @@
-{ config, pkgs, ... }:
-with import <stockholm/lib>;
-{
- services.matrix-synapse = {
- enable = true;
- settings = {
- server_name = "lassul.us";
- # registration_shared_secret = "yolo";
- database.name = "sqlite3";
- turn_uris = [
- "turn:turn.matrix.org?transport=udp"
- "turn:turn.matrix.org?transport=tcp"
- ];
- listeners = [
- {
- port = 8008;
- bind_addresses = [ "::1" ];
- type = "http";
- tls = false;
- x_forwarded = true;
- resources = [
- {
- names = [ "client" ];
- compress = true;
- }
- {
- names = [ "federation" ];
- compress = true;
- }
- ];
- }
- ];
- };
- };
- services.nginx = {
- virtualHosts = {
- "lassul.us" = {
- locations."= /.well-known/matrix/server".extraConfig = ''
- add_header Content-Type application/json;
- return 200 '${builtins.toJSON {
- "m.server" = "matrix.lassul.us:443";
- }}';
- '';
- locations."= /.well-known/matrix/client".extraConfig = ''
- add_header Content-Type application/json;
- add_header Access-Control-Allow-Origin *;
- return 200 '${builtins.toJSON {
- "m.homeserver" = { "base_url" = "https://matrix.lassul.us"; };
- "m.identity_server" = { "base_url" = "https://vector.im"; };
- }}';
- '';
- };
- "matrix.lassul.us" = {
- forceSSL = true;
- enableACME = true;
- locations."/_matrix" = {
- proxyPass = "http://[::1]:8008";
- };
- };
- };
- };
-}