summaryrefslogtreecommitdiffstats
path: root/lass/2configs/logf.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/logf.nix')
-rw-r--r--lass/2configs/logf.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/lass/2configs/logf.nix b/lass/2configs/logf.nix
deleted file mode 100644
index f141a94f..00000000
--- a/lass/2configs/logf.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ config, pkgs, ... }:
-with import <stockholm/lib>;
-let
- host-colors = {
- mors = "131";
- prism = "95";
- uriel = "61";
- shodan = "51";
- icarus = "53";
- echelon = "197";
- cloudkrebs = "119";
- };
- urgent = [
- "\\blass@blue\\b"
- ];
-in {
- environment.systemPackages = [
- (pkgs.writeDashBin "logf" ''
- export LOGF_URGENT=${pkgs.writeJSON "urgent" urgent}
- export LOGF_HOST_COLORS=${pkgs.writeJSON "host-colors" host-colors}
- ${pkgs.logf}/bin/logf ${concatMapStringsSep " " (name: "root@${name}") (attrNames config.lass.hosts)}
- '')
- ];
-}