summaryrefslogtreecommitdiffstats
path: root/lass/2configs/exim-smarthost.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/exim-smarthost.nix')
-rw-r--r--lass/2configs/exim-smarthost.nix62
1 files changed, 0 insertions, 62 deletions
diff --git a/lass/2configs/exim-smarthost.nix b/lass/2configs/exim-smarthost.nix
deleted file mode 100644
index 2a3a6b1e..00000000
--- a/lass/2configs/exim-smarthost.nix
+++ /dev/null
@@ -1,62 +0,0 @@
-{ config, lib, pkgs, ... }: with import <stockholm/lib>; let
-
- to = concatStringsSep "," [
- "lass@green.r"
- ];
-
- mails = import <secrets/mails.nix>;
-
-in {
- environment.systemPackages = [ pkgs.review-mail-queue ];
-
- krebs.exim-smarthost = {
- enable = true;
- dkim = [
- { domain = "lassul.us"; }
- ];
- ssl_cert = "/var/lib/acme/mail.lassul.us/fullchain.pem";
- ssl_key = "/var/lib/acme/mail.lassul.us/key.pem";
- primary_hostname = "lassul.us";
- sender_domains = [
- "lassul.us"
- ];
- relay_from_hosts = map (host: host.nets.retiolum.ip6.addr) [
- config.krebs.hosts.aergia
- config.krebs.hosts.blue
- config.krebs.hosts.coaxmetal
- config.krebs.hosts.green
- config.krebs.hosts.mors
- config.krebs.hosts.xerxes
- ];
- internet-aliases = map (from: { inherit from to; }) mails ++ [
- ];
- system-aliases = [
- { from = "mailer-daemon"; to = "postmaster"; }
- { from = "postmaster"; to = "root"; }
- { from = "nobody"; to = "root"; }
- { from = "hostmaster"; to = "root"; }
- { from = "usenet"; to = "root"; }
- { from = "news"; to = "root"; }
- { from = "webmaster"; to = "root"; }
- { from = "www"; to = "root"; }
- { from = "ftp"; to = "root"; }
- { from = "abuse"; to = "root"; }
- { from = "noc"; to = "root"; }
- { from = "security"; to = "root"; }
- { from = "root"; to = "lass"; }
- ];
- };
- krebs.iptables.tables.filter.INPUT.rules = [
- { predicate = "-p tcp --dport smtp"; target = "ACCEPT"; }
- ];
-
- security.acme.certs."mail.lassul.us" = {
- group = "lasscert";
- webroot = "/var/lib/acme/acme-challenge";
- };
- users.groups.lasscert.members = [
- "dovecot2"
- "exim"
- "nginx"
- ];
-}