summaryrefslogtreecommitdiffstats
path: root/lass/2configs/bitcoin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/bitcoin.nix')
-rw-r--r--lass/2configs/bitcoin.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/lass/2configs/bitcoin.nix b/lass/2configs/bitcoin.nix
deleted file mode 100644
index e9dd055f..00000000
--- a/lass/2configs/bitcoin.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- mainUser = config.users.extraUsers.mainUser;
-in {
-
- users.extraUsers = {
- bitcoin = {
- name = "bitcoin";
- description = "user for bitcoin stuff";
- home = "/home/bitcoin";
- useDefaultShell = true;
- createHome = true;
- packages = [ pkgs.electrum ];
- isNormalUser = true;
- };
- monero = {
- name = "monero";
- description = "user for monero stuff";
- home = "/home/monero";
- useDefaultShell = true;
- createHome = true;
- packages = [
- pkgs.monero
- pkgs.monero-gui
- ];
- isNormalUser = true;
- };
- };
- security.sudo.extraConfig = ''
- ${mainUser.name} ALL=(bitcoin) ALL
- ${mainUser.name} ALL=(monero) ALL
- '';
-}